DecoderProgrammer

Allgemeine Hinweise

Diese Seite beinhaltet alle jene Dinge, welche allgemeine Bedeutung haben und keinem Kapitel speziell zuzuordnen sind...
_______________________

Beim Start prüft der DecoderProgrammer ob die eingestellte Schnittstelle zur Verfügung steht. Das heißt, die Schnittstelle muss existieren und sie darf nicht von einer anderen Anwendung belegt sein.
Das Programm prüft dabei nicht, ob eine Verbindung zu einer Zentrale besteht.
Gibt es die Schnittstelle nicht oder wird sie von einem anderen Programm benutzt, erscheint eine Fehlermeldung und der Zugang zu den Programmiersystemen wird gesperrt.
Wenn Sie demzufolge auf einem PC, welcher keine Verbindung zur Modellbahn hat, z.B. eine Kennlinie erstellen oder eine Gruppe von CVs bearbeiten wollen, brauchen Sie nur eine auf diesem PC installierte Schnittstelle einzugeben und der Zugang wird freigegeben.

_______________________

Die Termini laden, speichern, lesen und schreiben
In dieser Hilfe werden Ihnen an vielen Stellen diese Bezeichnungen begegnen, um Missverständnisse auszuschließen werden die Termini wie folgt verwendet:

  • laden : öffnen oder laden einer Datei von einem Datenträger
  • speichern : sichern oder speichern einer Datei auf einem Datenträger
  • lesen : auslesen von Werten / Parametern aus einem Decoder
  • schreiben : übertragen von Werten / Parametern in einen Decoder

_______________________

Quickinfos und Tooltips
Nahezu alle Tasten, Textfelder u.a. Werkzeuge des DecoderProgrammers sind mit kurzen Hilfe-Informationen versehen.
Diese erläutern Ihnen die grundlegende Funktion des einzelnen Werkzeuges.
Um sich diese Infos anzeigen zu lassen, zeigen Sie mit der Maus auf das betr. Werkzeug und warten Sie eine Sekunde - der DecoderProgrammer zeigt dann die kurze Beschreibung an.

_______________________

Der DecoderProgrammer wird auf einem PC mit einer Bildschirmauflösung von 1024 x 768 Pixeln entwickelt.
Diese Auflösung kann heute (Jan. 2007) als Standard bezeichnet werden.
Wird der DecoderProgrammer mit einer Bildschirmauflösung von 800 x 600 Pixeln gestartet, erscheint in der Werkzeugleiste eine kleine Bildlaufleiste.
Mit dieser kann der rechte Teil des Fensters nach links über das Protokoll verschoben werden.


Dateien laden, speichern und kombinieren

Viele Modellbahner wollen die in die Decoder eingegebenen Werte / Parameter dauerhaft speichern oder auch an andere Modellbahner weitergeben.
Dazu bietet der DecoderProgrammer mehrere Möglichkeiten:

Sie können:

  • das Protokoll
    - drucken oder
    - in einer Datei auf einem Datenträger speichern
  • die Kennlinie
    - in einer Datei auf einem Datenträger speichern und
    - von einem Datenträger in den DecoderProgrammer laden
    - auf dem Standarddrucker ausdrucken
  • CV-Gruppen
    - in einer Datei auf einem Datenträger speichern
    - von einem Datenträger in den DecoderProgrammer laden
    - aus einer MoVe-Datei importieren
    - auf dem Standarddrucker ausdrucken

Das Format, in welchem die einzelnen Dateien vom DecoderProgrammer gespeichert werden ist immer gleich.
Dadurch ist es z.B. möglich, verschiedene Dateien in einer neuen Datei zusammenzufassen.

Beispiel:
Sie möchten ein Protokoll und eine Kennlinie zu einer Datei kombinieren und an einen Kollegen weitergeben.
Dann gehen Sie wie folgt vor:
→ schreiben oder lesen Sie die gewünschten CVs / Register
→ speichern Sie das daraus resultierende Protokoll z.B. unter Protokoll_1
→ erstellen Sie nun die Kennlinie. Dabei ist es ohne Belang, ob Sie diese Kennlinie auch in Ihren Decoder
schreiben - Sie können die Kennlinie auch ohne sie geschrieben zu haben gleich in eine Datei (z.B. Kennlinie_1)
speichern.

Zum kombinieren
→ wählen Sie den Menupunkt Datei > CV-Gruppen bearbeiten
→ zeigen Sie mit der Maus auf die noch leere Tabelle und klicken Sie die rechte Maustaste
→ klicken Sie auf Tabelle aus Datei laden
→ wählen Sie die Protokoll-Datei Protokoll_1
der DecoderProgrammer lädt das Protokoll in die Gruppen-Tabelle
→ klicken Sie nochmals mit der rechten Maustaste
→ klicken Sie auf Tabelle aus Datei laden
→ wählen Sie die Kennlinien-Datei Kennlinie_1
der DecoderProgrammer lädt die Kennlinien-Datei und hängt die Werte an das bereits geladene Protokoll an.

→ speichern Sie nun die Tabelle unter einem neuen Namen ab.


Decoder programmieren

Dieses kleine Programm ermöglicht Ihnen, Lokomotiven mit Decodern in folgenden Systemen über Ihren PC zu programmieren:

- fx- / mfx-Decoder (Motorolaformat, nur schreiben),
- DCC-Decoder
- Selectrix SX1

Zentrale | Motorola | DCC | SLX
6021 & 6051 | X |  |
IntelliBox IB | X | X | X
MasterControl MC | X | X |
Rautenhaus SLX850 & 825 |  | X | X
Lenz LZ100 & LV100 |  | X |
Lenz LZ100 & LI-USB |  | X |

Die IB kann des Weiteren die Adresse von verschiedenen Motorola-Decodern ermitteln.

Aufgrund der verschiedenen Zentralen, Systeme und der Unzahl der am Markt erhältlichen Decoder kann der
DecoderProgrammer nicht jede unlogische oder verbotene Eingabe von Parametern überwachen.
Die Parametrisierung eines Decoders liegt alleine in Ihrer Verantwortung !

_______________________

Informationen und weitere Hilfe finden Sie in der Tabelle links von diesem Text,
doppelklicken Sie dazu auf das betr. Stichwort.

Für Probleme, Fragen, Vorschläge, Anregungen usw. haben wir ein eigenes Support-Forum eingerichtet:

http://www.bahnhistorie.de/ > Supportforum für MoVe und DecoderProgrammer

Bitte nehmen Sie für Anfragen dieses Forum in Anspruch,
zum einen sind viele Fragen von allgemeiner Bedeutung und können dort von allen Interessierten zur Kenntnis genommen und diskutiert werden und
zum anderen kostet die Bearbeitung jeder persönlichen Mail Zeit, -Zeit, die dem eigentlichen Programmieren dann verloren geht.


DecoderProgrammer Motorola

Ort: Hauptmenu → System → Motorola / DCC

Motorola-Decoder programmieren mit der ControlUnit 6021 & 6051

► Während in der DCC-Welt überwiegend von CV-Programmierung gesprochen wird, verwendet Märklin den
Ausdruck Register . Um Abweichungen von der Märklin-Bedienungsanleitung zu vermeiden, wird im folgenden
der von Märklin benutzte Terminus verwendet

Um ein einzelnes Register zu ändern
→ stellen Sie die Lokomotive auf das Gleis.

Achten Sie unbedingt darauf, das sich keine weiteren Loks im gleichen Stromkreis befinden,
diese würden ausnahmslos mitgeändert !

→ Schalten Sie die 6021 aus und nach einigen Sekunden wieder ein
oder
drücken Sie auf der 6021 die Stop -Taste und danach die Go -Taste und halten Sie beide solange fest,
bis im Display die 99 aufblinkt (Reset).
→ wählen Sie die Option fx-Decoder oder mfx-Decoder,
 der Unterschied zwischen fx- und mfx-Decoder besteht lediglich darin, das beim mfx-Decoder Anfahr-
und Bremsverzögerung in zwei getrennten Registern (3 und 4) eingegeben werden.
→ wählen Sie dann das gewünschte Register 1) und
→ geben Sie im Feld Wert den neuen Wert an
→ klicken Sie dann auf schreiben

Damit startet der Programmiervorgang-, den aktuellen Stand können Sie in der Statuszeile am unteren Rand des Fensters verfolgen.

Anmerkung:
die Übertragung der erforderlichen Befehle wäre eigentlich in weniger als 1 Sekunde zu bewerkstelligen, aber der Decoder braucht immer etwas Zeit, um die empfangenen Daten zu ' verdauen'. Aus diesem Grund wartet das Programm nach jedem Kommando eine kleine Weile, bevor es den nächsten Befehl sendet.
Ein positiver Nebeneffekt ist dabei, dass Sie auf diese Weise den Ablauf der Programmierung leicht verfolgen können:
• zuerst schaltet der Programmer die 6021 stromlos (Power off),
• stellt die von Märklin vorgegebene Adresse 80 ein,
• sendet den Fahrtrichtungs-Umschaltbefehl und
• schaltet die 6021 wieder ein (Power on).
nun sollte die Lok 5 - 6x langsam blinken 2)
• dann überträgt das Programm die Adresse des zu ändernden Registers und
• bestätigt sie durch einen 2. Umschaltbefehl.
danach blinkt die Lok 8 - 10x schnell.
• anschließend wird der neue Wert in das Register geschrieben und
• wieder ein Umschaltbefehl gesendet.
nun blinkt die Lok wieder 5 - 6x langsam
• danach schaltet MoVe die Stromversorgung aus und
• nach 3 Sekunden wieder ein.

Damit ist die Übertragung erfolgreich verlaufen und das Register wurde mit dem neuen Wert überschrieben.

► Wenn Sie Register 1 (dig. Adresse) geändert haben, trägt das Programm die neue Adresse ins Fahrpult ein,
Sie könnten dann gleich eine 'Probefahrt' unternehmen.

1) die Einträge in der Liste sind nur als Eingabehilfe zu verstehen -
andere Register / CVs können selbstverständlich auch eingegeben werden.

2) das Blinkverhalten bei mfx-Decodern kann von dem o.a. Blinksignal abweichen.


Blinksignale
Während DCC-Decoder mit der jeweiligen Steuereinheit 'kommunizieren' und eine entspr. Rückmeldung ausgeben, kennen fx- und mfx- Decoder keine diesbezügliche Funktion. Ihre 'Antwort' auf die Programmierbefehle besteht aus einer Reihe von Blinksignalen, welche über das Spitzenlicht der Lok ausgegeben werden.

Bei den getesteten Decodern traten folgende Blinksignale auf:

fx-Decoder |  |
Lok im Programmiermodus | gleichmäßiges Blinken in längeren Abständen | ―― ―― ――
Register eingestellt | gleichmäßiges Blinken in kürzeren Abständen | ― ― ― ―
wieder im Programmiermodus | gleichmäßiges Blinken in längeren Abständen | ―― ―― ――
kein Licht | Programmierung beendet |

mfx-Decoder |  |
Lok im Programmiermodus | sehr kurzes Blinken in längeren Abständen | – – – –
Register eingestellt | doppeltes Blinken in längeren Abständen | – – – – – – – –
schreiben in Register | längeres Aufleuchten | ――
wieder im Programmiermodus | kurzes Blinken in längeren Abständen | – – – –
kein Licht | Programmierung beendet |


Die Konfigurationsvariable CV 29

Bei Decodern nach NRMA -Norm *) können im Register / CV 29 verschiedene Einstellungen vorgenommen werden:

  • Fahrtrichtung normal / invers
  • 14 / 27 oder 28 / 128 Step-Modus
  • Analogbetrieb ja / nein
  • RailCom1) ein / aus
  • Fahrverhalten beim Beschleunigen (Geschwindigkeitskennlinie)
  • Basis-Adresse aus CV 1 oder lange Adresse aus CV / / 18

Mit der Taste CV lesen können Sie die aktuellen Werte einlesen,
der DecoderProgrammer liest die CV und zeigt den Wert dezimal und binär an.

Zum Ändern der einzelnen Werte klicken Sie auf die jeweilige <> -Taste.

Falls Sie mindestens 1 Wert geändert haben, können Sie die neue Konfiguration mit der Taste
CV schreiben in den Decoder zurückschreiben.

*) National Model Railroad Association

1) RailCom ist eingetragenes Warenzeichen der Fa. Lenz Elektronik GmbH


CV-Gruppen bearbeiten

Im DCC-Bereich ist es möglich, mehrere CVs zu lesen bzw. zu schreiben.
Die CVs werden dazu in einer Tabelle erfasst und nachfolgend insgesamt abgearbeitet.

Um ein Gruppe erstellen / bearbeiten / laden zu können wählen Sie die gewünschte Zentrale und öffnen im Menu Datei den Punkt CV-Gruppe bearbeiten.
Der DecoderProgrammer zeigt daraufhin anstelle des Fahrpults eine kleine Tabelle an:

In die 1. Spalte S/L wird die Richtung angegeben:
- S für Schreiben der Parameter
- L für das Lesen einer CV
→ zum Schreiben vorgesehene CVs werden farblich hervorgehoben.
→ vereinfachte Eingabe

In die Spalten 2 und 3 werden die CV und der betreffende Wert eingetragen.
Beim Lesen kann die Spalte Wert selbstverständlich frei bleiben, der DecoderProgrammer trägt den Wert ein.

Die Anzahl der zu lesenden oder zu schreibenden CVs spielt keine Rolle, auch ist es möglich Lese-und Schreibvorgänge abwechselnd vorzunehmen.
Sie können demzufolge zur Kontrolle einer Schreiboperation einen Lesezugriff auf die gleiche CV folgen lassen.

Wenn sich die Maus über der Tabelle befindet, können Sie mit der rechten Maustaste ein PopUp-Menu aufrufen welches u.a. folgende Punkte enthält:

  • Tabelle Lesen / schreiben
    Damit starten Sie den Schreib- oder Lesevorgang zum Decoder,
    der DecoderProgrammer arbeitet die Tabelle ab der 1. Zeile ab.
  • Tabelle drucken
    Der Ausdruck der Tabelle erfolgt ohne weitere Abfrage auf dem Standarddrucker.
  • Reihe erweitern
    Sie müssen selbstverständlich nicht alle CVs von Hand eintippen, bei entspr. großen Bereichen kann der DecoderProgrammer das wesentlich schneller [image].
    Geben Sie die 1. CV des Bereichs ein und wählen Sie diesen Menupunkt
    - der DecoderProgrammer zeigt Ihnen den Startwert an und braucht nur noch die letzte, zu erzeugende CV.
  • 1. Spalte alles 'S' chreiben' bzw. 1. Spalte alles 'L' esen
    dieser Menupunkt füllt die 1. Spalte mit dem gewünschten Zeichen und markiert damit alle CVs der Tabelle
    zum Lesen oder Schreiben.
  • mit den Punkten aktuelle Zeile löschen und 1 Zeile einfügen können Sie einzelne Zeilen aus der Tabelle entfernen bzw. weitere Zeilen einfügen.
  • Tabelle in Datei speichern und Tabelle aus Datei laden bieten die Option, die Tabelle in einer ASCII-Datei (*.txt) zu speichern bzw. aus einer solchen zu laden.
  • MoVe-Datei importieren
    Falls Sie Nutzer der Modellbahn-Verwaltungssoftware MoVe sind, können Sie dort angelegte Decoder-Dateien importieren und mit dem DecoderProgrammer weiter bearbeiten.
  • Tabelle in MoVe-Format exportieren
    Sie können eine Tabelle ins MoVe-Format exportieren und dort dem Decoder bzw. der Lok zuordnen.

► Solange die CV-Tabelle sichtbar ist, ist das Panel mit den Zentralen gesperrt und
► ein Öffnen der CV-Gruppentabelle ist nur möglich, wenn die Decoder-Auswahl auf DCC eingestellt ist.
► zu ladende Dateien werden an das Ende der Tabelle angefügt !
► verschiedene Decoder "vertragen" diese schnelle Art der Programmierung nicht so ohne Weiteres -
besonders bei ESU-Decoder wurde öfters ein Schreibbefehl ignoriert oder falsch ausgeführt.

vereinfachte Eingabe / Änderung in der S / L -Spalte
in der ersten Spalte wird -wie bereits beschrieben- festgelegt, ob die CV geLesen oder geSchrieben werden soll.
Die Eingabe von L bzw. S kann dabei auf verschiedene Art und Weise erfolgen:

  • durch Klicken mit der Maus auf das betr. Feld und Tippen der jeweiligen Taste
  • durch wählen des Menupunktes alles S und alles L
  • durch Drücken und Halten der Shift- oder Strg- oder Alt- Taste und klicken in die betreffende Zeile,
    dabei erzeugt die Shift- Taste S,
    die Strg- Taste L und
    die Alt- Taste ein Leerzeichen
  • durch Klicken auf den Kopf der ersten Spalte erscheinen zwei Auswahlbuttons mit welchen die Wahl zwischen S und L vorgenommen werden kann.
    Durch wiederholtes Klicken auf den Spaltenkopf kann zwischen dem Aussehen von Bild 1 und Bild 2 umgeschaltet werden.

    Bild 1 Bild 2


Ort: Hauptmenu → System → Motorola / DCC

DCC-Decoder programmieren

 ► DCC-Decoder können nur mit der IB, der MC oder mit einer Lenz-Zentrale programmiert werden !

Um eine CV (engl.: ConfigurationsVariable) des Decoders zu lesen
→ stellen Sie die Lokomotive auf das Programmiergleis
→ wählen Sie dann das gewünschte Register 1) und
→ klicken Sie dann auf lesen

Der Programmer liest daraufhin das entspr. Register aus und zeigt den gelesenen Wert im gleichnamigen Feld.
In der Statuszeile wird der komplette Empfangsstring angezeigt.

Um eine CV zu schreiben
→ stellen Sie die Lokomotive auf das Programmiergleis
→ wählen Sie dann das gewünschte Register
→ und geben Sie den neuen Wert im gleichnamigen Feld ein
→ klicken Sie dann auf schreiben

Der Programmer schreibt damit den neuen Parameter in die CV.
In der Statuszeile können Sie den Ablauf der Programmierung verfolgen.

► Das Lesen einer CV dauert wesentlich länger als das Schreiben !

1) die Einträge in der Liste sind nur als Eingabehilfe zu verstehen -
andere Register / CVs können selbstverständlich auch eingegeben werden.


Ort: Hauptmenu → Extras → Decoder-Hersteller

Decoder-Hersteller

unter Datei > Decoder-Hersteller anzeigen können Sie eine Tabelle mit allen nach NMRA *) registrierten Decoder-Herstellern aufrufen.
Die Tabelle liest dazu die Datei .txt aus dem Arbeitsverzeichnis ein.
Die Spalte Code enthält die Herstellerkennung, welche in der CV 8 der DCC-Decoder gespeichert ist.

Sie können
- die Tabelle spaltenweise sortieren - klicken Sie dazu auf den gewünschten Spaltenkopf,
- jeden Eintrag der Tabelle nach eigenem Ermessen editieren,

Alle Eintragungen werden beim Verlassen des Programms in der o.a. Datei gespeichert.

Falls Sie vorhandene Hersteller entfernen oder weitere hinzufügen wollen, können Sie die o.a. Datei mit jedem Text-Editor bearbeiten, beachten Sie jedoch bei Erweiterungen das vorhandene Spaltenformat.

*) National Model Railroad Association


Fahrpult

Vorweg, die Fahrpulte sind keineswegs als Ersatz für eine Modellbahn-Steuerungssoftware gedacht und erheben auch keinen Anspruch auf einen Preis für gelungenes Design [image], sie dienen alleine dem Zweck, geänderte Parameter schnell überprüfen zu können.
Die Fahrpulte weichen -je nach verwendetem System (DCC, Selectrix, Lenz)- in kleinen Details von dem unten beschriebenen Fahrpult ab.

Der Fahrtregler kann
- mit gedrückter linker Maustaste auf jede beliebige
Position gezogen werden
- durch Klicken auf seine hellgraue Laufbahn nach
oben bzw. nach unten verstellt werden
- durch konstantes Drücken der linken Maustaste auf
der Laufbahn kontinuierlich bewegt werden
- mit dem Scrollrad der Maus bewegt werden.

Die Taste anfahren können Sie zur Kontrolle der Anfahrbeschleunigung benutzen, geben Sie dazu die gewünschte Fahrstufe ein und klicken Sie auf anfahren .
Der DecoderProgrammer fährt damit die Lok sofort mit der eingestellten Fahrstufe an.

Der Unterschied zwischen der Taste <<< >>>

und den Tasten

<<< >>> schaltet die Fahrtrichtung relativ um, d.h.,
- fuhr die Lok vorwärts, fährt sie nach dem Klick auf diese
Taste rückwärts,
- fuhr die Lok rückwärts, fährt sie nach dem Klick vorwärts.
Die Lok wechselt somit auf jeden Fall die Richtung !

diese Tasten stellen die absolute Fahrtrichtung ein,
d.h., unabhängig von der aktuellen Fahrtrichtung der Lok fährt die Lok in die gewählte Richtung.
Je nach aktueller Fahrtrichtung kann das dazu führen, das ein Klick auf diese Tasten ohne sichtbare Auswirkung bleibt:
- war die aktuelle Fahrtrichtung z.B. vorwärts, wird sich nach einem Klick auf die Taste
die Fahrtrichtung nicht ändern.
- war die aktuelle Fahrtrichtung z.B. rückwärts, wird sich nach einem Klick auf die Taste
die Fahrtrichtung nicht ändern.

Diese Tasten sind nach einem Decoder-Einbau von Nutzen, man kann z.B. leicht ermitteln, ob die Lok nach einem Vorwärts-Befehl auch diese Fahrtrichtung einnimmt.

► Bei Verwendung der IB muss der erweiterte / IB-Befehlssatz freigegeben sein.
► für die 6021 & 6051 stehen diese Tasten nicht zur Verfügung

Adressbereiche

Zentrale | fx | mfx | DCC
6021 & 6051 | 1 - 80 | 1 - 80 | -
IntelliBox IB | 1 - 80 | 1 - 256 | 1 - 9999
MasterControl MC | 1 - 80 | 1 - 256 | 1 - 9999
Lenz LZ100 & LV100 | - | - | 1 - 9999
Lenz LZ100 & LI-USB | - | - | 1 - 9999

Die Tabelle zeigt die Adressbereiche, welche mit der jeweiligen Zentrale verwaltet werden können.
Obwohl von Märklin nicht ausdrücklich erwähnt, können die meisten mfx-Decoder auch mit Adressen bis 256 programmiert werden.


MotorolaProgrammer

wenn's nicht klappen will...
überprüfen Sie die folgenden Punkte:

Hardware
Einstellungen / Erfahrungen
IntelliBox
MasterControl
6021& 6051
Selectrix
Fehlermeldungen in der Statuszeile
USB-Verbindung
Hauptgleisprogrammierung (DCC)
Sonstiges

Hardware
→ sind alle Geräte (Trafo, Zentrale 1), Booster o.ä.) eingeschaltet ?

→ ist die Steuereinheit mit dem PC verbunden ?
wenn nein, stellen Sie die Kabelverbindung her.

→ ist die richtige Schnittstelle (COM) 1) eingestellt ?
wenn nein, wählen Sie eine freie Schnittstelle (COM1...)

→ steckt das Kabel auf der eingestellten Schnittstelle ?

→ stimmen Baudrate in Steuereinheit und PC überein ?
wenn nein, passen Sie die Baudrate im Programmer an,
Hilfe dazu finden Sie hier

→ funktionieren die beiden Power-Tasten ?
wenn nein, wird die Programmierung auch nicht gelingen,
d.h., Sie müssen auf jeden Fall die Funktion dieser Tasten herstellen

→ hat die Lok einen fx- / mfx- oder einen DCC-Decoder ?
Sie können einen DCC-Decoder nicht über das fx- / mfx-Protokoll oder umgekehrt programmieren.

→ steht die Lok auf dem 'richtigen' Gleis ?
fx- und mfx-Decoder werden auf dem normalen Fahrgleis programmiert
(auf diesem Gleis darf sich keine andere Lok befinden !)
Ausnahme ist die IB, hier gehört die Lok immer aufs Programmiergleis.
Ab Rel. 2.0.7 wird das benötigte Gleis in der Statuszeile angezeigt.

Lokomotiven mit DCC-Decoder werden auf dem Programmiergleis programmiert.
Sowohl die IB als auch die MC besitzen dafür besondere Ausgänge.

Zentrale | fx- / mfx- Decoder | DCC-Decoder
6021 / 6051 | normales Fahrgleis | -
IB | Programmiergleis | Programmiergleis
MC | normales Gleis | Programmiergleis

→ hat die Lok Kontakt zum Gleis ?
Schalten Sie zur Kontrolle das Spitzenlicht (Function) ein und aus !
______________________________

Einstellungen
→ bei verschiedenen Decodern kann es bei eingeschaltetem Spitzenlicht vorkommen,
das die Programmierung fehlschlägt, deshalb vor dem Programmieren alle Funktionen
und die Spitzenbeleuchtung ausschalten !

→ beim Schreiben von Kennlinien kann es vorkommen, das die Kommandos zum Schreiben zu schnell
aufeinander folgen.
Dadurch werden falsche Werte in die CVs / Register geschrieben.
Mit der Angabe des Delays (engl.: Verzögerung) kann die zeitliche Verzögerung zwischen 0 und 10 Sekunden
eingestellt werden.
> Hauptfenster > Kennlinie > delay
empfohlener Wert > 500 mSec.
Dieser Fehler trat häufig beim Testen von ESU-Decodern auf.
______________________________

Intellibox
→ IntelliBox: sind die erforderlichen Parameter eingestellt ?
► in der IB muss der IB-Befehlssatz freigegeben sein.
siehe dazu im IB-Handbuch 2) Seite 44/45 → Kapitel 3.11 → Grundeinstellungen →
Interface → Syntax → 6050 und IB-Syntax.
► die Adresse 80 muss das Datenformat 'Motorola alt' bekommen
siehe dazu im IB-Handbuch Seite 56 → Kapitel 4.5.3
► die Sonderoption 663 muss auf '1' gesetzt werden
siehe dazu im IB-Handbuch Seite 47 → Kapitel 3.14
Diese Parameter werden in der IB dauerhaft gespeichert und müssen deshalb nur einmal eingegeben werden .
► die IB muss mit 2 Stopbits (→ Schnittstelle) angesprochen werden
______________________________

MasterControl
→ MasterControl: die MC muss mindestens auf Rel. 1.4.3g aufgerüstet sein !

→ Beim Programmieren mit der MC stellte sich heraus, das selbst baugleiche (!) Motorola-Decoder durchaus
unterschiedlich reagieren können. Dadurch wurde eine weitere Programmierroutine notwendig.
Durch Wahl der Tasten   I   und   II  können Sie zwischen beiden Varianten wählen.
 Leider kann niemand mit Bestimmtheit sagen, wann welche Routine die Richtig ist,
da hilft nur probieren
______________________________

Selectrix
Beim Einsatz einer CentralControl 2000 von Trix kann es vorkommen, dass die CC2000 nicht schnell genug die Quittung für den Übergang in den Programmiermodus sendet.
- setzen in diesem Fall die Verzögerung (delay) auf 2000 mSec oder höher oder
- starten Sie den DecoderProgrammer mit dem Parameter /CC2000.
Der Programmer schaltet damit die CC2000 in den Programmiermodus, fordert aber keine Quittung für den
erfolgten Wechsel an.
Stattdessen erscheint eine Abfrage, in welcher Sie den erfolgreichen Wechsel in den Programmiermodus bestätigen
müssen.
Ob sich die CC2000 im Programmiermodus befindet, erkennen Sie am 'P' im Display der CC2000.
______________________________

6021 & 6051
→ bei der zum Testen verwendeten 6021 & 6051 waren folgende DIP-Schalter gesetzt:

Interface 6051 Zentrale 6021

1 | 2 | 3 | 4 | 1 | 2 | 3 | 4
ON | ON |  |  |  | ON |  |
 |  | OFF | OFF | OFF |  | OFF | OFF

Ansicht von hinten

► die 6021 & 6051 muss mit 2 Stopbits (→ Schnittstelle) angesprochen werden

______________________________

Fehlermeldungen in der Statuszeile
Sofern bei der Kommunikation zwischen der IB bzw. der MC und einem DCC-Decoder Probleme auftreten, zeigt der DecoderProgrammer die Fehlermeldung in der Statuszeile an:

Fehlermeldung | Bedeutung
Error | dieser Fehler kommt vor allem bei falschen oder fehlenden Parametern vor
Busy | die Zentrale ist bereits von anderer Stelle in den Programmiermodus gesetzt worden
Short! | Kurzschluss auf dem Programmiergleis
No decoder | kein Decoder gefunden
No ack | nach der Programmierung oder bei der Abfrage wurde kein ACK empfangen
Timeout | beim Programmieren gab es einen Zeitfehler

______________________________

Sonstiges
→ rückwärts und vorwärts
diese Tasten benötigen den P50X / erweiterten / IB-Befehlssatz :
- dieser steht bei der 6021/6051 nicht zur Verfügung
- die IB muss wie folgt eingestellt sein:
siehe dazu im IB-Handbuch → Grundeinstellungen → Interface → Syntax → 6050 und IB-Syntax.
- die MC unterstützt dieses Merkmal automatisch

→ das gruppenweise Schreiben von CVs kann nur bei DCC-Decodern durchgeführt werden - wenn als
Decodertyp fx oder mfx ausgewählt ist, lässt sich die Gruppentabelle nicht öffnen.

______________________________

Hauptgleisprogrammierung
→ während das aktuelle Lokdatenformat bei der IB auch auf Motorola eingestellt sein darf, verlangt
die MC explizit die Angabe 'DCC'.

1) Beachten Sie bei USB-Schnittstellen, das diese immer nur solange existieren, wie das jeweilige
USB-Gerät hardwaremäßig mit dem PC verbunden und betriebsbereit ist.

2) Ausgabe vom Dezember 2002 (5. Auflage, Grundlage Softwareversion 1.3)


Function Mapping ESU LokPilot V3.0

Beide Tabellen sind in die Bereiche Funktionsausgänge und Funktionstasten aufgeteilt,

mit Hilfe der oberen Tabelle können Sie die Effekte und die Ausgangsspannung / Helligkeit der Funktions-Ausgänge bestimmen.
In der Spalte Funktion steht Ihnen eine Reihe von Lichteffekten zur Auswahl,
was die einzelnen Lichteffekte bewirken, entnehmen Sie bitte der Bedienungsanleitung des Decoders.
Die Helligkeit können Sie mit dem Schieberegler unterhalb dieser Spalte einstellen.

Die untere Tabelle enthält die internen Funktionen des Decoders. Diese können Sie ebenfalls einer oder mehreren F-Tasten zuweisen.

Die rechten Bereiche der Tabellen enthalten neben den F-Tasten auch die Auswahl für die stehende Lok (ST.) und für die fahrende Lok (Fa.)
Beide Zustände werden ebenso wie die 15 F-Tasten nochmals in Vorwärts- und Rückwärtsfahrt unterschieden.

Um das FM in den Decoder zu schreiben,
- speichern Sie Ihre Eingaben in einer Datei Datei > alle CVs in Datei speichern
- schließen Sie das FM-Fenster und öffnen Sie das Programmierfenster für Ihre Zentrale.
- laden Sie die eben erzeugte Datei als Datei > CV-Gruppe bearbeiten
- schreiben Sie die Parameter in den Decoder.


Function Mapping Kühn T145 und Viessmann 5246

Die Tabelle ist in die Bereiche Funktionsausgänge und Funktionstasten aufgeteilt.
Legen Sie zuerst in der Spalte Einschaltbedingung fest, wann der Ausgang aktiv sein soll:

In der Spalte Lichteffekt steht Ihnen eine Reihe von Lichteffekten zur Auswahl,
was die einzelnen Lichteffekte bewirken, entnehmen Sie bitte der Bedienungsanleitung des Decoders.

Im Bereich Funktionstasten können Sie bestimmen, welche F-Taste welchen Ausgang ein- und ausschalten soll.
Ausgang A ist jedoch fest verdrahtet und kann nicht geändert werden.

In der kleinen Tabelle für die CV 55 können Sie die Blinkfrequenz (Zykluszeit der Effekte*) ) der Lichteffekte und die Helligkeit (Dimmrate) einstellen.

In CV 56 können Sie drei weitere Parameter ändern.

Um das FM in den Decoder zu schreiben,
- speichern Sie Ihre Eingaben in einer Datei Datei > alle CVs in Datei speichern
- schließen Sie das FM-Fenster und öffnen Sie das Programmierfenster für Ihre Zentrale.
- laden Sie die eben erzeugte Datei als Datei > CV-Gruppe bearbeiten
- schreiben Sie die Parameter in den Decoder.

*) nicht beim Viessmann 5246


Function Mapping Lenz GoldSerie
In der Tabelle Helligkeit können Sie die Leuchtkraft der Funktionsausgänge regeln.
Benutzen Sie dazu die beiden Schieberegler.

Die beiden großen Tabellen sind in die Bereiche Funktionsausgänge und Funktionstasten aufgeteilt.
Die obere Tabelle zeigt die internen Funktionen, die untere Tabelle die Funktionsausgänge an.
Bestimmen Sie im Bereich Funktionstasten, welche Taste auf welche interne Funktion bzw. auf welchen Ausgang wirken soll.

In den Tabellen Effekte können Sie verschieden Lichteffekte einstellen.
Beachten Sie, das die Effekte für die einzelnen Ausgänge unterschiedlich sind

Um das FM in den Decoder zu schreiben,
- speichern Sie Ihre Eingaben in einer Datei Datei > alle CVs in Datei speichern
- schließen Sie das FM-Fenster und öffnen Sie das Programmierfenster für Ihre Zentrale.
- laden Sie die eben erzeugte Datei als Datei > CV-Gruppe bearbeiten
- schreiben Sie die Parameter in den Decoder.


Function Mapping NMRA

Die Tabelle ist in die Bereiche Funktionsausgänge und Funktionstasten aufgeteilt.
Legen Sie zuerst fest, welche Funktion der Funktionsausgang ausführen soll.
In der Spalte Funktion steht Ihnen eine Reihe von Lichteffekten zur Auswahl,
was die einzelnen Lichteffekte bewirken, entnehmen Sie bitte der Bedienungsanleitung des Decoders.

In der Spalte Richtung können Sie wählen, ob der Effekt nur bei Vorwärts-, bei Rückwärtsfahrt oder immer aktiv sein soll.
Wählen Sie anschließend, mit welcher F-Taste Sie diese Funktion / diesen Ausgang ein- bzw. ausschalten wollen.

Um das FM in den Decoder zu schreiben,
- speichern Sie Ihre Eingaben in einer Datei Datei > alle CVs in Datei speichern
- schließen Sie das FM-Fenster und öffnen Sie das Programmierfenster für Ihre Zentrale.
- laden Sie die eben erzeugte Datei als Datei > CV-Gruppe bearbeiten
- schreiben Sie die Parameter in den Decoder.


Function Mapping Tams LD-G-8
Hinweise:
- Aufgrund der ungewöhnlichen Bitzuordnung bei diesem Decoder befindet sich die F0-Taste nicht an der
eigentlich zu erwartenden 1. Stelle, sondern hinter der F4-Taste
- die ebenfalls eigenartige Anordnung der CVs in den CV- Spalten ist kein Fehler im Programm
sondern die Folge der sonderbaren Zuordnung der CVs auf die jeweiligen Ausgänge seitens des Herstellers.

Das Verbinden der Decoderausgänge mit den Funktionstasten geschieht bei diesem Decoder recht einfach:
- wählen Sie den gewünschten Ausgang durch Klicken auf 'X1 ... X4'
- setzen Sie dann in der gleichen Zeile das Häkchen unter die F-Taste, mit welcher Sie den Ausgang schalten wollen.
Sie können auch mehrere Tasten zum Schalten eines Ausgangs verwenden oder mit einer Taste mehrere
Ausgänge schalten.
- Im Bereich Dimmen / Helligkeit können Sie die Höhe der Ausgangsspannung festlegen. Damit lässt sich z.B. die
Helligkeit der Stirnlampen einer Lok präzise einstellen.
- in der Spalte Effekte können Sie wählen, ob der Ausgang mit besonderen Effekten (Blitzlicht, Blinklicht usw.) versehen
werden soll.

Beispiel:
Ausgang X2 soll mit mittlerer Helligkeit langsam blinken, wenn die Taste F3 gedrückt wird.
-setzen Sie das Häkchen in der Zeile X2 in die Spalte F3 (CV 58 -> 4)
- positionieren Sie den Schieberegler auf etwa 40 (CV 53 -> 40)
- wählen Sie aus der Liste den Eintrag blinken 1 Hz (CV -> 128)

Um das FM in den Decoder zu schreiben,
- speichern Sie Ihre Eingaben in einer Datei Datei > alle CVs in Datei speichern
- schließen Sie das FM-Fenster und öffnen Sie das Programmierfenster für Ihre Zentrale.
- laden Sie die eben erzeugte Datei als Datei > CV-Gruppe bearbeiten
- schreiben Sie die Parameter in den Decoder.


Function Mapping Tams FD-M

Dieser Decoder ist sehr logisch und übersichtlich aufgebaut und das Mapping dementsprechend einfach [image],
leider lässt sich durch die vorgegeben Breite des Bildschirms nicht das komplette Mapping in einer Tabelle darstellen. Die untere Tabelle ist demzufolge die 'Fortsetzung' der oberen.
Sie erkennen das u.a. daran, dass der Wechsel von einem Ausgang zu einem anderen in einer der Tabellen den Satzzeiger der anderen Tabelle autom. mitführt.

Hinweis:
Der Ausgang AUX5 darf nur mit max. 10 mA belastet werden und benötigt somit eine nachfolgende Verstärkung. Die in der unteren Tabelle einstellbaren Optionen stehen daher für diesen Ausgang nicht zur Verfügung.

Beispiel:
Ausgang AUX3 soll bei Vorwärtsfahrt mit mittlerer Helligkeit leuchten, wenn die Taste F5 gedrückt ist.
-setzen Sie das Häkchen in der Zeile AUX3 in die Spalte F5 (CV 39 -> 4)
- positionieren Sie den Schieberegler im Bereich Dimmen auf etwa 32 (CV 51 -> 33)
- wählen Sie im Bereich Richtung den Eintrag Ausgang aus bei rückwärts (CV 55 -> 8)

Um das FM in den Decoder zu schreiben,
- speichern Sie Ihre Eingaben in einer Datei Datei > alle CVs in Datei speichern
- schließen Sie das FM-Fenster und öffnen Sie das Programmierfenster für Ihre Zentrale.
- laden Sie die eben erzeugte Datei als Datei > CV-Gruppe bearbeiten
- schreiben Sie die Parameter in den Decoder.


Function Mapping Tran DCX-Serie

Die Tabelle zeigt im linken Bereich die Funktionsausgänge und rechts davon die Funktionstasten.

Legen Sie zuerst fest, mit welcher Taste welcher Ausgang geschaltet werden soll.
Beispiel: Ausgang D soll mit F2 geschaltet werden
- klicken Sie unter Funktionsausgänge in die Zeile D
- folgen Sie der Markierung nach rechts in die Spalte F2
- markieren Sie mit der Maus das kleine Kästchen
- fertig
Der DecoderProgrammer errechnet den Bitwert und trägt in in das CV-Feld (in diesem Beispiel CV 36 = 8 ) ein.

In der unteren Tabelle können Sie u.a. die Ausgangsspannung der Funktionsausgänge festlegen (dimmen).
Falls mit einem Ausgang eine Beleuchtung geschaltet wird, könnten Sie damit deren Helligkeit regeln.
Nun ist es aber nicht immer gewollt, alle Ausgänge zu dimmen - dafür gibt es in der oberen Tabelle die Spalte Dimmen.
In dieser Spalte können Sie die Ausgänge markieren, die mit der reduzierten Ausgangsspannung angesteuert werden sollen.

Um das FM in den Decoder zu schreiben,
- speichern Sie Ihre Eingaben in einer Datei Datei > alle CVs in Datei speichern
- schließen Sie das FM-Fenster und öffnen Sie das Programmierfenster für Ihre Zentrale.
- laden Sie die eben erzeugte Datei als Datei > CV-Gruppe bearbeiten
- schreiben Sie die Parameter in den Decoder.


Function Mapping Uhlenbrock 76400
Das Verbinden der Decoderausgänge mit den Funktionstasten geschieht bei diesem Decoder recht einfach:
- wählen Sie den gewünschten Ausgang durch Klicken auf die Zeile
- Licht vorne,
- Licht hinten,
- Sonderfunktionsausgang A1,
- ...
Setzen Sie dann in der gleichen Zeile das Häkchen unter die F-Taste, mit welcher Sie den Ausgang schalten wollen.
Sie können auch mehrere Tasten zum Schalten eines Ausgangs verwenden oder mit einer Taste mehrere
Ausgänge schalten.

Mit der CV 49 können Sie verschiedene Optionen des Decoders aktivieren / deaktivieren.
Beachten Sie dabei, dass die Einstellung
- Datenformat nur DCC zusammen mit
- Datenformat nur Motorola
dazu führt, das der Decoder keinen Fahrbefehl mehr ausführt.

Mit der CV 50 können Sie die Helligkeit -gemeinsam für alle Funktionsausgänge- einstellen.

Um das FM in den Decoder zu schreiben,
- speichern Sie Ihre Eingaben in einer Datei Datei > alle CVs in Datei speichern
- schließen Sie das FM-Fenster und öffnen Sie das Programmierfenster für Ihre Zentrale.
- laden Sie die eben erzeugte Datei als Datei > CV-Gruppe bearbeiten
- schreiben Sie die Parameter in den Decoder.


Function Mapping Zimo MX-Serie

Die Tabelle ist in die Bereiche Funktionsausgänge und Funktionstasten aufgeteilt.

Klicken Sie als erstes auf den zu bearbeitenden Ausgang,
Legen Sie dann fest, welche Funktion / Effekte der Funktionsausgang ausführen soll.
In der gleichnamigen Spalte können Sie dazu die verschiedensten Effekte auswählen.

Wählen Sie dann in der Spalte Richtung, ob der gewählte Effekt nur bei Vorwärtsfahrt, Rückwärtsfahrt oder immer aktiv werden soll.

Zum Schluss bestimmen Sie noch, mit welcher Funktionstaste der Ausgang ein- und ausgeschaltet werden soll.

Beispiel: Sie wollen an den Ausgang FA 2 eine Lampe anschließen, welche bei Rückwärtsfahrt aufblitzt
- klicken Sie in die Zeile FA 2
- öffnen Sie die Liste in der Spalte Funktion / Effekte (auf das kleine Dreieck klicken) und wählen Sie Blitzlicht
- öffnen Sie die Liste in der Spalte Richtung (auf das kleine Dreieck klicken) und wählen Sie rückwärts
- setzen Sie als Letztes ein Häkchen in die Spalte F2
Um das FM in den Decoder zu schreiben,
- speichern Sie Ihre Eingaben in einer Datei Datei > alle CVs in Datei speichern
- schließen Sie das FM-Fenster und öffnen Sie das Programmierfenster für Ihre Zentrale.
- laden Sie die eben erzeugte Datei als Datei > CV-Gruppe bearbeiten
- schreiben Sie die Parameter in den Decoder.


Function Mapping

Bei den meisten der herkömmlichen Decodern sind die Ausgänge fest mit den Funktionstasten verbunden. So liegt z.B. die Anfahrbeschleunigung bzw. die Bremsverzögerung meist auf F4. Nicht jeder Modellbahner ist mit dieser festen Zuordnung glücklich, zumal das auch noch von Hersteller zu Hersteller unterschiedlich ist.
Die neueren Decoder tragen diesem nicht mehr zeitgemäßen Umstand Rechnung und bieten die Möglichkeit, jeden Decoder-Ausgang mit jeder Funktionstaste zu verbinden.
Man kann also einen Ausgang mit einer oder auch mehreren Tasten verbinden oder mit einer Taste einen oder mehrere Ausgänge schalten.
(letzteres empfiehlt sich gerade dann, wenn der zulässige Strom eines einzelnen Ausganges überschritten wird.)
Der neudeutsche Ausdruck bezeichnet dieses freie Zuordnen als Function Mapping (FM).

Um ein FM durchzuführen, sind bestimmte CVs mit entspr. Werten zu beschreiben.
Es ist jedoch nicht immer einfach, die erforderlichen CVs zu finden und mit den für das FM nötigen Werten zu versehen, zumal jeder Hersteller hierbei sein 'eigenes Süppchen kocht' und sich kaum jemand an die NMRA-Vorgaben hält.
Ein typisches Beispiel ist die Bezeichnung der Decoder-Ausgänge:
- lt. NMRA werden sie als FA1...bezeichnet,
- bei ESU nennt man sie AUX1...
- bei Kühn und Lenz heißen sie A, B...
- bei Tran haben sie mal gar keinen Namen und mal heißen sie F1...
- Tams nennt sie X1...

Der DecoderProgrammer unterstützt momentan das FM
- nach NMRA,
- des Kühn T145,
- für die Lenz GoldSerie
- des ESU Lokpilot V3.0 und
- für die Tran DCX-Serie
- des Tams LD-G-8
- des Uhlenbrock 76400
- der Zimo MX-Serie
- des Viessmann 5246

Bedienung:
Die Bedienung ist für alle Decoder grundsätzlich gleich, sieht aber durch die Leistungsmerkmale des jeweiligen Decoders unterschiedlich aus.
Die vom Hersteller (hoffentlich) mitgelieferte Funktionsbeschreibung des Decoders sollte auf jeden Fall griffbereit sein.
Der DecoderProgrammer kann keinesfalls alle evt. auftretenden Fragen beantworten.

- wählen Sie als erstes in der Tabelle Funktionsausgänge in der Spalte Ausgang den Ausgang des Decoders,
den Sie mit einer Taste verbinden wollen
- legen Sie dann in der Spalte Funktion fest, wie der Ausgang arbeiten soll (ein/aus, Blinklicht, usw).
diese Werte sind abhängig vom Decoder und können von den vorgegebenen Parametern abweichen.
- klicken Sie dann in der gleichen Zeile die F-Taste, mit der Sie den Ausgang schalten wollen.
Der DecoderProgrammer errechnet die CV-Werte und weist sie der jeweiligen CV zu.

Die internen Funktionen wie z.B. Rangiergang oder Anfahr- und Bremsverzögerung (ABV) werden ebenso wie die Ausgänge des Decoders durch Funktionstasten geschaltet. Durch die teilweise verwirrende Verteilung der F-Tasten auf die dazugehörigen CVs kann es besonders bei ESU und Lenz leicht passieren, dass eine Taste ungewollt zwei oder noch mehr Ausgänge ansteuert. Der DecoderProgrammer markiert aus diesem Grund jede F-Taste, sobald sie in einer Tabelle einer Funktion oder einem Ausgang zugewiesen wurde. Der betr. Spaltenkopf und das markierte Feld werden dabei gelb dargestellt.

► es ist nicht möglich, die Eingaben direkt in den Decoder zu schreiben - die Daten müssen zuvor in einer Datei gespeichert werden und können später als CV-Gruppe geladen und geschrieben werden.

Um das Mapping zu speichern
- speichern Sie Ihre Eingaben in einer Datei, → Menu Datei > alle CVs speichern
damit wird das gesamte Mapping neu gespeichert,

wenn Sie jedoch nicht alle Zuordnungen ändern wollen
- wählen Sie den Menupunkt Datei > nur CVs > 0 speichern
damit werden nur die geänderten Parameter in der Datei gespeichert.
Das kann jedoch dazu führen, dass sich das neue Mapping mit dem bereits vorhandenen überschneidet.

► falls nur wenige Änderungen anliegen, können Sie die CV-Parameter auch in der Zwischenablage
(neudeutsch: Clipboard) ablegen und anschließend in eine Gruppendatei eintragen
► vorhandene Mappings können aus einer Gruppendatei eingelesen und dargestellt werden.

Da das FM -wie bereits erwähnt- bei jedem Hersteller andere CVs belegt, kann unter dem Menupunkt Extras > Einlesedatei erzeugen eine Datei erstellt werden, in welcher alle benötigten CVs enthalten sind. Sie können diese Datei als Gruppendatei laden und den Decoder auslesen.

Details zu den einzelnen Decodern finden Sie hier:
ESU LokPilot V3.0
Kühn T145
Lenz GoldSerie
Tams LD-G-8
Tams FD-M
Tran DCX-Serie
Uhlenbrock 76400
Viessmann 5246
Zimo MX...
NMRA


getestete Decoder / Lokomotiven

Decoder / Lokomotive | Protokoll | Best. Nr. | Anzahl
ESU Lokpilot Basis | DCC |  | 1
Kühn T 145 | DCC |  | 3
Märklin ER 20 | Motorola fx | 36849 | 2
Märklin HWZ | Motorola mfx Sound | 26610 | 1
Märklin Köf | Motorola fx | 36808 | 1
Märklin ER 20 | Motorola fx | 36847 | 1
Märklin 185-CL 009 | Motorola fx | 36854 | 1
Märklin ?? |  | 37369 | 1
Märklin BR 151 Railion | Motorola mfx | 39582 | 1
Märklin BR V 80 | Motorola fx | 36080 | 2
Märklin Baureihe 120.0 | Motorola fx (?) | 37537 | 1
Märklin Baureihe 290 | Motorola mfx | 37900 | 1
Märklin 'Klopstock' | Motorola mfx | 37974 | 1
Märklin Bigboy | Motorola mfx | 37991 | 1
Tams LD W7 | DCC |  | 1
Tams LD G8 | DCC |  | 1
Tams LD G9 | DCC |  | 1
Tams LD-G21 | DCC | FL 4327 | 1
Trix 66830 (Standardwerte) | Selectrix |  |
Trix 66836 (erw. Kennwerte) | Selectrix |  |
Trix 66838 (erw. Kennwerte) | Selectrix |  |
Rautenhaus SLX830 (erw. Kennwerte) | Selectrix |  |
Rautenhaus SLX870 (SX und DCC) | Selectrix |  |

Wenn auch Sie zur Vervollständigung der obigen Liste beitragen wollen, senden Sie bitte eine Email
mit Angabe des getesteten Decoders oder der Best. Nr. der getesteten Lok an

email@henningvoosen.de

Vielen Dank für Ihre Mitarbeit


Hauptgleisprogrammierung (DCC)

Hinweis:
Die Hauptgleisprogrammierung (HGPR) unter DCC darf nicht mit der Programmierung von fx / mfx-Decodern -ebenfalls auf dem Hauptgleis- verwechselt werden.
Während bei letzterer alle auf dem Gleis befindlichen Lokomotiven zugleich programmiert würden, ist es bei der DCC-HGPR ohne weiteres möglich, eine Lok während des normalen Fahrbetriebs zu programmieren.

Die HGPR wird momentan nur von der IB und der MC unterstützt.
________________

zur Programmierung:
Nach der Wahl einer der vorgenannten Zentralen
- klicken Sie auf DCC
- aktivieren Sie HGPR
- tragen Sie im Fahrpult die digitale Adresse der zu programmierenden Lok ein
- wählen Sie unter CV die zu beschreibende CV
- geben Sie im Feld Wert den zu schreibenden neuen CV-Wert ein
- klicken Sie auf die Taste schreiben

Die erfolgreiche Programmierung erkennen Sie daran, dass die Lok dabei leicht vor sich hin 'muckelt'.

weitere Hinweise:
- die Lok darf während der Programmierung nicht fahren
- ältere Decoder reagieren bei Adressen > 99 nicht auf die HGPR
- Änderungen werden sofort und ohne Rückfrage durchgeführt
wenn Sie also die Adresse in CV 1 ändern sollten, 'heisst' die Lok ab dann auch anders
- während das aktuelle Lokdatenformat bei der IB auch auf Motorola eingestellt sein darf, verlangt die MC
explizit die Angabe 'DCC'.


Wichtige Hinweise zu fx- und mfx-Decodern

Grundsätzlich können Sie alle Register zwischen 0 und 999 mit allen Werten zwischen 0 und 255 beschreiben.
Ob das dem Decoder bekommt, ist eine andere Sache [image] und liegt alleine in Ihrer Verantwortung.

Die folgende Tabelle enthält einige Register, welche geändert werden können:
Quelle: Märklin.de/FaQ

Register | Bedeutung | Wertebereich | Bemerkung
01 | digitale Adresse | 1 ... 80 |
03 | Anfahrbeschleunigung | 1 ... 63 | nur bei mfx
04 | Bremsverzögerung | 1 ... 63 |
05 | Höchstgeschwindigkeit | 1 ... 63 | bei C-Sinus Motoren nicht ändern
08 | Decoder zurückstellen | 8 |
63 | Lautstärke der Geräuschelektronik | 1... xx | nicht zu hoch einstellen (Beschädigung)
75 | Zweite Adresse der Lok | 1 ... 80 |

Die folgenden Werte können -auf eigenes Risiko- geändert werden :

Register | Bedeutung | Wertebereich | Bemerkung
02 | Anfahrspannung |  | diesen Wert auf keinen Fall ändern
53 | Lastregelung (Motorwirkungsgrad) | 1 ... 63 |
54 | Lastregelung (Regelgüte) | 1 ... 63 |
55 | Lastregelung (Schwungmasse) | 1 ... 63 |
64 | Bremsenquietschen | 1... 63 |
73 | Verhalten bei Spannungsunterbrechung | 3 oder 7 |
79 | Höchstgeschwindigkeit im Analogbetrieb | 1 ... 63 |

Weitere Details finden Sie unter
http://www.maerklin.de/faq/showthreaded.php?Cat=&Board=DigitalDecoder&Number=166&page=0&view=collapsed&sb=5&o=&fpart=1


Ort: Hauptmenu → System → Motorola / DCC

Motorola-Decoder programmieren mit der IntelliBox (IB)

► Während in der DCC-Welt überwiegend von CV-Programmierung gesprochen wird, verwendet Märklin den
Ausdruck Register . Um Abweichungen von der Märklin-Bedienungsanleitung zu vermeiden, wird im folgenden
der von Märklin benutzte Terminus verwendet

Um diese Funktion nutzen können, muss die IB folgende Einstellungen bekommen:
► in der IB muss der IB-Befehlssatz freigegeben sein.
siehe dazu im IB-Handbuch 1) Seite 44/45 → Kapitel 3.11 → Grundeinstellungen →
Interface → Syntax → 6050 und IB-Syntax.
► die Adresse 80 muss das Datenformat 'Motorola alt' bekommen
siehe dazu im IB-Handbuch Seite 56 → Kapitel 4.5.3
► die Sonderoption 663 muss auf '1' gesetzt werden
siehe dazu im IB-Handbuch Seite 47 → Kapitel 3.14
Diese Parameter werden in der IB dauerhaft gespeichert und müssen deshalb nur einmal eingegeben werden .
________________

Um ein einzelnes Register zu ändern
→ stellen Sie die Lokomotive auf das Programmiergleis.
→ wählen Sie die Option fx-Decoder oder mfx-Decoder,
 der Unterschied zwischen fx- und mfx-Decoder besteht lediglich darin, das beim mfx-Decoder Anfahr-
und Bremsverzögerung in zwei getrennten Registern (3 und 4) eingegeben werden.
→ wählen Sie dann das gewünschte Register 2) und
→ geben Sie im Feld Wert den neuen Wert an
→ klicken Sie dann auf schreiben

Damit startet der Programmiervorgang-, den aktuellen Stand können Sie in der Statuszeile am unteren Rand des Fensters verfolgen.

Anmerkung:
die Übertragung der erforderlichen Befehle wäre eigentlich in weniger als 1 Sekunde zu bewerkstelligen, aber der Decoder braucht immer etwas Zeit, um die empfangenen Daten zu ' verdauen'. Aus diesem Grund wartet das Programm nach jedem Kommando eine kleine Weile, bevor es den nächsten Befehl sendet.
Ein positiver Nebeneffekt ist dabei, dass Sie auf diese Weise den Ablauf der Programmierung leicht verfolgen können:
• zuerst startet das Programm einen Reset auf der IB
• danach wechselt die IB in den Programmiermodus (Relais klickt)
• stellt die von Märklin vorgegebene Adresse 80 ein,
• sendet den Fahrtrichtungs-Umschaltbefehl und
• schaltet den Programmiermodus wieder aus (Relais klickt wieder).
nun sollte die Lok 5 - 6x langsam blinken 3)
• dann überträgt das Programm die Adresse des zu ändernden Registers und
• bestätigt sie durch einen 2. Umschaltbefehl.
danach blinkt die Lok 8 - 10x schnell.
• anschließend wird der neue Wert in das Register geschrieben und
• wieder ein Umschaltbefehl gesendet.
nun blinkt die Lok wieder 5 - 6x langsam
• danach schaltet MoVe die Stromversorgung der IB aus und
• nach 3 Sekunden wieder ein.

Damit ist die Übertragung erfolgreich verlaufen und das Register wurde mit dem neuen Wert überschrieben.

► Wenn Sie Register 1 (dig. Adresse) geändert haben, trägt das Programm die neue Adresse ins Fahrpult ein,
Sie können dann gleich eine 'Probefahrt' unternehmen.

1) Ausgabe vom Dezember 2002 (5. Auflage, Grundlage Softwareversion 1.3)

2) die Einträge in der Liste sind nur als Eingabehilfe zu verstehen -
andere Register / CVs können selbstverständlich auch eingegeben werden.

3) das Blinkverhalten bei mfx-Decodern kann von dem o.a. Blinksignal abweichen.


Geschwindigkeitskennlinie schreiben und lesen

Mit Hilfe des DecoderProgrammers können Geschwindigkeitskennlinien von DCC-Decodern nach eigenen Vorstellungen gestaltet werden.

► DCC-Decoder können nur mit der IB bzw. der MC programmiert werden.

→ wählen Sie die betreffende Zentrale
→ wählen Sie Datei > Geschwindigkeitskennlinie bearbeiten

Sie öffnen damit ein separates Fenster mit einer Tabelle, welche die CVs 67 bis 94 in horizontaler Anordnung enthält.

Alle Parameter stehen zu Anfang auf 0.

Sie können nun die Kennlinie auf verschiedene Arten erzeugen:

  • durch klicken der betr. Scrollbar am oberen Tabellenrand.
    das jedoch ist sehr zeitaufwendig und eigentlich nur zur Feinjustage gedacht.
  • Schneller geht's durch ziehen der roten Marken auf die gewünschte Position
  • Noch schneller geht's so:
    → ziehen Sie die erste Marke (CV 67) auf die Startgeschwindigkeit und die letzte Marke (CV 94) auf die Endgeschwindigkeit der Lok
    → klicken Sie dann auf Datei > lineare Kennlinie oder
    → klicken Sie auf die Taste lineare Kennlinie erzeugen in der Werkzeugleiste oder
    → öffnen Sie mit der rechten Maustaste das PopUp-Menu und klicken Sie auf lineare Kennlinie zeichnen.
    Der DecoderProgrammer berechnet die Zwischenwerte und stellt die sich ergebende Kennlinie dar.
  • Legen Sie wie im vorangegangenen Punkt beschrieben, Start- und Endgeschwindigkeit fest und
    → klicken Sie dann auf Datei > exponentiale Kennlinie oder
    → klicken Sie auf die Taste exponentiale Kennlinie erzeugen in der Werkzeugleiste oder
    → öffnen Sie mit der rechten Maustaste das PopUp-Menu und klicken Sie auf exponentiale Kennlinie zeichnen.

    Auf der Tabelle erscheinen daraufhin 2 'Anfasser',
    durch ziehen der Anfasser können Sie eine nahezu beliebige Kennlinie erzeugen.
    ► Etwaige Ungenauigkeiten können durch die jeweiligen Scrollbar korrigiert werden.
    ► Beim Überschreiten der zulässigen Grenzwerte wird die Kennlinie nicht gezeichnet.
    ► durch Ändern von Start- oder Endwert wird die Kennlinie neu gezeichnet.

Sie können ein vertikales Lineal einblenden, indem Sie auf den gewünschten CV-Wert am unteren Tabellerand klicken.

Sobald die Kennlinie die gewünschte Form hat, klicken Sie auf Kennlinie > Kennlinie in Decoder schreiben
Der DecoderProgrammer schreibt damit die Parameter in die einzelnen CVs.
Das Schreiben in eine CV dauert ca. 1 Sekunde, sodass der gesamte Schreibvorgang etwa eine halbe Minute dauert.
► beim Schreiben von Kennlinien kann es vorkommen, dass die Kommandos zum Schreiben zu schnell aufeinander folgen.
Dadurch werden u. U. falsche Werte in die CVs / Register geschrieben.
Mit der Angabe des Delays (engl.: Verzögerung) kann die zeitliche Verzögerung zwischen 0 und 10 Sekunden eingestellt werden.
> Hauptfenster > Kennlinie > delay
empfohlener Wert > 500

Um eine Kennlinie aus einem Decoder auszulesen, klicken Sie auf Kennlinie > Kennlinie aus Decoder auslesen
► Das Auslesen einer CV dauert wesentlich länger als das Schreiben, Wartezeiten bis zu 10 Sekunden pro CV
sind 'normal', der komplette Lesevorgang kann somit leicht mehrere Minuten dauern. *)
► Sie können eine Kennlinie unter Datei > Kennlinie speichern im Arbeitsverzeichnis abspeichern.

*) Die o.a. Zeiten beziehen sich auf die IB, die MC liest die Daten in wesentlich kürzerer Zeit.


Lange Adressen

Viele DCC-Decoder bieten die Möglichkeit, einer Lokomotive 2 Adressen zuzuordnen.
Das ist zum ersten die Adresse in CV 1 (Basis-Adresse), welche zwischen 1 und 255 (Motorola 1...80) liegen darf und zum anderen eine sogenannte 'lange' Adresse in CV 17 und CV 18.
In CV 29 wird eingestellt, auf welche der beiden Adressen die Lok 'hören' soll.

Die 'lange Adresse' kann unterschiedlich lang sein, bei der IB reicht der Adressbereich biss 9.999 und bei der MC sogar bis 10.239 .

Um die lange Adresse verwenden zu können, muss sie umgerechnet und in die CVs 17 und 18 eingetragen werden.
Die Umrechnungsformel für die Werte über 255 ist nicht ganz einfach und führt oft zu endlosem Ausprobieren.
Außerdem muss in CV 29 ggf. noch die neue Adresse aktiviert werden.

Mit dem DecoderProgrammer können Sie einfach und schnell lange Adressen lesen, schreiben und berechnen.

Da die Zentralen unterschiedliche Adressbereiche unterstützen und auch die Decoder längst nicht alle 'gleich gebaut' sind, sollten Sie sich vor der Programmierung darüber informieren, welche Adressen Sie mit Ihrer Zentrale dem Decoder 'zumuten' dürfen.
Blindes Drauflos-Programmieren kann zu irreparablen Schäden am Decoder führen.
________________

Adressen lesen
mit dieser Taste liest der DecoderProgrammer die Basisadresse aus CV 1 und die lange Adresse aus CV 17 und CV 18.
Beide Adressen werden dezimal dargestellt, die lange Adresse wird autom. als aktuelle Adresse eingestellt.

schreiben
Sie können sowohl die Basis-Adresse in CV 1 als auch die lange Adresse in CV 17 und CV 18 einzeln oder auch gemeinsam schreiben / ändern.
Das Schreiben der langen Adresse stellt diese (wie beim Lesen) als aktuelle Adresse ein.

CV 29 lesen
Wie bereits erwähnt, wird in CV 29 die aktuelle Adresse festgelegt.
Bit 5 (Wertigkeit 32) entscheidet, welche der beiden Adressen die aktuelle ist.

Bit 5 | aktuelle Adresse
0 | Adresse in CV 1
1 | lange Adresse

Nach dem Klick auf die Taste zeigt Ihnen der DecoderProgrammer den Wert dezimal und binär an.
Bit 5 wird fett dargestellt.
Änderungen an CV 29 sind hier nicht möglich !

Basis-Adresse aktivieren
Das Lesen oder Schreiben der langen Adresse führt -wie zuvor beschrieben- zur Aktivierung derselben.
Mit dieser Taste können Sie das Bit 5 in CV 29 auf 0 setzen und so die Basis-Adresse aus CV 1 als aktuelle Adresse festlegen.

CV17 und CV 18 lesen
beim Klick auf diese Taste liest der DecoderProgrammer beide CVs einzeln aus und zeigt sie in den gleichnamigen Feldern an.
► Dieser Lesevorgang führt nicht zur Änderung der jeweils aktuellen Adresse !
Mit der Taste [image] können Sie dann den dezimalen Wert der Adresse berechnen.

diese Tasten helfen Ihnen bei der Umrechnung einer langen Adresse in die CV -Werte und umgekehrt.

Wenn Sie z.B. die Adresse 4711 umrechnen wollen, geben Sie diesen Wert in das linke Feld ein und klicken Sie auf die obere der beiden Tasten.
Der DecoderProgrammer errechnet die Werte für CV 17 (210) und CV 18 (103) und zeigt sie in den beiden rechten Feldern an.

Umgekehrt ist es möglich, Werte aus CV 17 und CV 18 zu lesen und daraus die lange Adresse zu ermitteln.
Geben Sie dazu die beiden Werte in die rechten Felder ein und klicken Sie auf die untere Taste.
Beispiel: CV 17 = 205 und CV 18 = 5 ergibt 3333


Leistungsmerkmale und Funktionen

Der DecoderProgrammer ermöglicht die schnelle und einfache Programmierung von

  • fx-
  • mfx-
  • DCC- und
  • Selectrix-Decodern.

Die Programmierung erfolgt mit Hilfe einer Zentrale zur Steuerung von Modellbahnen.
Unterstützte Zentralen z.Zt.:

  • 6021 & 6050/51 von Märklin
  • IntelliBox (IB) von Uhlenbrock
  • MasterControl (MC) von Tams
  • SLX850 & SLX825 von Rautenhaus
  • LZ100 & LV100 von Lenz (seriell)
  • LZ100 & LI-USB von Lenz (USB)

CV- / Register-Bereich: 1 ... 999
Werte-Bereich (Parameter): 0 ... 255

Die Kommunikation mit der Zentrale erfolgt über die serielle Schnittstelle (COM) oder bei der MC und Lenz auch über USB.
Verwendbar sind alle installierten und freien seriellen Schnittstellen.
Der DecoderProgrammer kann alle nutzbaren Schnittstellen autom. ermitteln.

CVs / Register können bei fx- und mfx-Decoder (bauartbedingt) nur geschrieben, bei DCC- und SLX-Decodern geschrieben und ausgelesen werden.

Nach der NMRA *) genormte Hersteller sind mit ihren Codes (CV 8) in einer Tabelle aufgelistet.

Der Programmierfortschritt wird bei fx-, mfx- und SLX-Decodern in der Statuszeile angezeigt,

Jede Schreib- / Lese-Aktion wird in einem Protokoll festgehalten,
das Protokoll kann in einer Datei gespeichert und / oder ausgedruckt werden.
Damit ist eine einfache Weitergabe der Daten an andere Modellbahner möglich.

Der DecoderProgrammer unterstützt die Funktion der IB, Lokomotiven mit unbekannter Adresse zu ermitteln.

Die bei vielen DCC-Decodern vorhandene Kennlinie (CV 67 ... 94) kann grafisch dargestellt und mit 1 Klick geschrieben bzw. gelesen werden,
der DecoderProgrammer bietet als Vorgabe
- 1 lineare Kennlinie
- 1 nach eigenen Vorstellungen formbare Kennlinie (Bezierkurve)
- jede Kennlinie kann insgesamt angehoben / abgesenkt werden.
- jede CV kann einzeln justiert werden (mittels ScrollRegler oder durch Ziehen mit der Maus)

Jede Kennlinie kann
- ausgedruckt
- in einer Datei gespeichert oder
- aus einer Datei geladen werden.

Lange Adressen (max. 5-stellig) können mit 1 Tastenklick gelesen, geschrieben und berechnet werden.

Die Konfigurationsvariable CV 29 ist im Klartext beschrieben und kann durch einfaches Anklicken eingestellt werden. Die Umrechnung der verschiedenen Bits in dezimale Werte entfällt damit.

Bei DCC-Decodern können CVs gruppenweise geschrieben / gelesen werden, dazu werden die gewünschten CVs in einer Tabelle eingetragen und nachfolgend gemeinsam abgearbeitet. Solche Tabellen können auf einem Datenträger gespeichert und natürlich auch wieder geladen werden.

Mit MoVe erzeugte Decodertabellen können in eine Gruppentabelle importiert werden.

Der DecoderProgrammer ermöglicht das bei den neueren Decodern eingebaute FunctionMapping durch wenige Mausklicks.

Programmierte Lokomotiven können mit einem kleinen Fahrpult auf Funktion geprüft werden,
das Fahrpult enthält u.a.
- eine ScollBar zur Wahl von 14, 27, 28 oder 128 Fahrstufen
- einen Schieberegler zum Einstellen der Geschwindigkeit
- CheckBoxen für die Funktionen1...8 (1...4 bei 6021)
- eine Taste zum Testen der Anfahrbeschleunigung (Anfahren mit einer frei wählbaren Fahrstufe)
- 2 Tasten zur Testen der absoluten Fahrtrichtung (nicht bei 6021)

*) National Model Railroad Association


Ort: Hauptmenu → System → Lenz

DCC-Decoder programmieren mit einer Lenz-Zentrale

 Um eine CV (engl.: ConfigurationsVariable) des Decoders zu lesen
→ stellen Sie die Lokomotive auf das Programmiergleis
→ wählen Sie dann das gewünschte Register 1) und
→ klicken Sie dann auf lesen

Der DecoderProgrammer liest daraufhin das entspr. Register aus und zeigt den gelesenen Wert im gleichnamigen Feld.

Um eine CV zu schreiben
→ stellen Sie die Lokomotive auf das Programmiergleis
→ wählen Sie dann das gewünschte Register
→ und geben Sie den neuen Wert im gleichnamigen Feld ein
→ klicken Sie dann auf schreiben

Der DecoderProgrammer schreibt damit den neuen Parameter in die CV.
In der Statuszeile können Sie den Ablauf der Programmierung verfolgen.

► da die Lenz-Zentrale den Schreibvorgang nicht quittiert, empfiehlt sich ein nachfolgender Lesevorgang
der gerade geschriebenen CV zur Kontrolle der übertragenen Daten.

1) die Einträge in der Liste sind nur als Eingabehilfe zu verstehen -
andere Register / CVs können selbstverständlich auch eingegeben werden.


MotorolaProgrammer

Überlassungsbedingungen für das Programm ' Decoder Programmer'

Bitte lesen Sie diese Überlassungsbedingungen sorgfältig durch, bevor Sie das Programm verwenden.
Der Lizenzvertrag gilt als rechtsgültiger Vertrag zwischen Ihnen als natürliche oder als juristische Person und dem Autor für die oben bezeichnete Software sowie aller zu dieser Software gehörenden Medien, Beschreibungen usw.
Indem Sie die Software installieren, verwenden, kopieren oder sonst wie darauf zugreifen, erklären Sie sich mit allen Bestimmungen dieses Lizenzvertrages einverstanden.
Falls Sie auch nur einer Bestimmung dieses Lizenzvertrages nicht zustimmen, sind Sie nicht berechtigt, die Software zu verwenden.

Es wird ausdrücklich darauf hingewiesen, dass es nach Stand der Technik nicht möglich ist, Computer-Software so zu erstellen, das sie in allen Situationen, unter allen Gegebenheiten oder Bedingungen, auf jedem Gerät und zu jeder Zeit fehlerfrei arbeitet. Vertragsgegenstand ist daher nur eine im Sinne der Beschreibung und Bedienungsanleitung grundsätzlich nutzbare Software.

Die Software wird unter Ausschluss jeglicher Gewährleistung lizenziert.

Die Software ist urheberrechtlich geschütztes Eigentum des Autors !

Lizenzvertrag
Durch diesen Lizenzvertrag gewährt Ihnen der Autor ein zeitlich nicht begrenztes, unentgeltliches Nutzungsrecht an dem im Titel näher bezeichneten Programm.
Sie sind berechtigt, beliebig viele Kopien der Software herzustellen, innerhalb Ihres Unternehmens oder Ihrer Institution zu installieren, darauf zuzugreifen, auszuführen oder in anderer Art und Weise mit ihr zu arbeiten.

Sie sind nicht berechtigt, die Software zu decompilieren, zu entschlüsseln, zu disassemblieren oder anderweitig zu verändern !

Sie sind nicht berechtigt, die Software oder Teile davon weiter zu lizenzieren, zu verkaufen, zu vermieten, zu verleasen, zu verleihen oder in irgendeiner anderen Form ohne ausdrückliche, schriftliche Genehmigung des Autors zu vermarkten, an Dritte weiterzugeben oder Dritten zugängig zu machen.

Unbeschadet weiterer Rechte des Autors erlischt die Ihnen gewährte Lizenz zu Nutzung der Software automatisch sobald Sie gegen die Bestimmungen dieses Vertrages verstoßen. In einem solchen Fall verpflichten Sie sich, sämtliche Kopien der Software zu vernichten.

Warnung
Diese Software ist nicht fehlertolerant und wurde nicht für eine Verwendung in gefahrenträchtiger Umgebung entwickelt oder hergestellt, in der ein störungsfreier Betrieb erforderlich ist.
Die Software darf nicht eingesetzt werden, wenn es durch ihren Ausfall oder durch ihr nicht ordnungsgemäßes Funktionieren zu Todesfällen, Personenschäden oder schwerwiegenden Schäden an Sachen oder der Umwelt kommen kann.

Haftung
Jeder Benutzer verwendet das Programm ausschließlich auf eigenes Risiko !

Der Autor haftet nicht für Schäden, die der Anwender oder Dritte durch die Verwendung der Software verursachen oder erleiden.
In keinem Fall haftet der Autor für entgangenen Umsatz oder Gewinn oder sonstige Vermögensschäden die bei der oder durch die Verwendung dieses Programms entstehen können.

Der Autor haftet auch nicht für den Verlust von Daten und daraus resultierende direkte, indirekte, spezielle, logisch folgende, beiläufige oder einschließende Schäden, welche durch den Gebrauch oder die Unmöglichkeit des Gebrauchs des Softwareprodukts verursacht werden können.
Vorgenanntes gilt auch für den Fall, das der Autor von der Möglichkeit solcher Schädigungen in Kenntnis gesetzt worden ist.


Ort: Hauptmenu → System → Motorola / DCC

Motorola-Decoder programmieren mit der MasterControl (MC)

► Während in der DCC-Welt überwiegend von CV-Programmierung gesprochen wird, verwendet Märklin den
Ausdruck Register . Um Abweichungen von der Märklin-Bedienungsanleitung zu vermeiden, wird im folgenden
der von Märklin benutzte Terminus verwendet

Um ein einzelnes Register zu ändern
→ stellen Sie die Lokomotive auf das normale Fahrgleis.

Achten Sie unbedingt darauf, das sich keine weiteren Loks im gleichen Stromkreis befinden,
diese würden ausnahmslos mitgeändert !

→ wählen Sie die Option fx-Decoder oder mfx-Decoder,
 der Unterschied zwischen fx- und mfx-Decoder besteht lediglich darin, das beim mfx-Decoder Anfahr-
und Bremsverzögerung in zwei getrennten Registern (3 und 4) eingegeben werden.
→ wählen Sie dann das gewünschte Register 1) und
→ geben Sie im Feld Wert den neuen Wert an
→ klicken Sie dann auf schreiben

Damit startet der Programmiervorgang-, den aktuellen Stand können Sie in der Statuszeile am unteren Rand des Fensters verfolgen.

→ Beim Programmieren mit der MC stellte sich heraus, das selbst baugleiche (!) Motorola-Decoder durchaus
unterschiedlich reagieren können. Dadurch wurde eine weitere Programmierroutine notwendig.
Durch Wahl der Tasten   I   und   II  können Sie zwischen beiden Varianten wählen.
 Leider kann niemand mit Bestimmtheit sagen, wann welche Routine die Richtig ist,
da hilft nur probieren

Anmerkung:
die Übertragung der erforderlichen Befehle wäre eigentlich in weniger als 1 Sekunde zu bewerkstelligen, aber der Decoder braucht immer etwas Zeit, um die empfangenen Daten zu ' verdauen'. Aus diesem Grund wartet das Programm nach jedem Kommando eine kleine Weile, bevor es den nächsten Befehl sendet.
Ein positiver Nebeneffekt ist dabei, dass Sie auf diese Weise den Ablauf der Programmierung leicht verfolgen können:
• zuerst schaltet der Programmer die MC stromlos (Power off) und
• wieder Power ein (Power on)
• danach wird die MC 2 x initialisiert
nun sollte die Lok langsam blinken 2)
• anschließend wird gewünschte Register eingestellt
• und bestätigt
damit sollte die Lok schnell blinken
• dann wird der Parameter (Wert) übertragen
• und bestätigt
• jetzt sollte die Lok wieder langsam blinken
• danach schaltet der Programmer die Stromversorgung aus und
• nach 3 Sekunden wieder ein.

Damit ist die Übertragung erfolgreich verlaufen und das Register wurde mit dem neuen Wert überschrieben.

► Wenn Sie Register 1 (dig. Adresse) geändert haben, trägt das Programm die neue Adresse ins Fahrpult ein,
Sie könnten dann gleich eine 'Probefahrt' unternehmen.

1) die Einträge in der Liste sind nur als Eingabehilfe zu verstehen -
andere Register / CVs können selbstverständlich auch eingegeben werden.

2) das Blinkverhalten bei mfx-Decodern kann von dem o.a. Blinksignal abweichen.


Motorola-Decoder auslesen

Mit der IB ist es möglich, bei Lokomotiven mit Motorola-Decodern *) die digitale Adresse zu ermitteln.

Dazu benutzt der DecoderProgrammer eine Programmroutine der IB.
Um die Lok zu finden, wird jede Adresse -bei 1 beginnend- mit mittlerer Fahrstufe angesprochen.
Die IB erkennt an der Zunahme der Stromaufnahme, dass die Lok gefunden wurde.
Das bedeutet aber auch, wenn die Adresse erreicht wird f ä h r t d i e L o k !!!
Das Programmiergleis sollte sich demzufolge nicht am Tischrand befinden [image].

Um eine Adresse zu ermitteln
→ stellen Sie dazu die Lok auf das Programmiergleis,
→ wählen Sie die IB und
→ klicken Sie auf

Der DecoderProgrammer startet damit die IB-Routine, welche jede Adresse einzeln anspricht ...
und dementsprechend lange dauern kann - Wartezeiten bis zu 2 Minuten sind nicht ausgeschlossen [image] .
In der Statuszeile wird die benötigte Suchzeit ausgegeben.

Sobald die Adresse gefunden wurde, zeigt der DecoderProgrammer die Antwort der IB in der Statuszeile an.

Falls Ihnen die Warterei zu lange dauert, klicken Sie 2 x auf die STOP -Taste.
Allerdings gilt das nur für den DecoderProgrammer - die IB führt die Suchroutine zu Ende und kann nur durch einen Reset zum Aufgeben bewegt werden.

► Erfahrungen die bei den Test gemacht wurden zeigen, dass die Suche
keinesfalls 100%ig arbeitet. Besonders bei Lokomotiven mit größeren Anfahrverzögerungen
kann es vorkommen, dass die IB die Lok nicht erkennt.

*) getestet und erkannt werden
- Delta-Decoder
- Decoder mit DIP-Schaltern
- fx-Decoder
- mfx-Decoder
- PIC-Decoder
- DCC-Decoder (MotorolaProtokoll)
- ...


Das Programmiergleis

An verschiedenen Stellen in dieser Hilfe ist von der Programmierung auf dem Programmiergleis bzw. auf dem Fahrgleis (oft auch als Hauptgleis bezeichnet) die Rede.
Die Zuordnung, wann welcher Decoder auf welchem Gleis zu programmieren ist abhängig von
- der Decoderart (DCC. fx /mfx, Selectrix) und von
- der verwendeten Zentrale.

Die 6021 benötigt kein spezielles Programmiergleis, da die Programmierbefehle über den gleichen Ausgang gesendet werden wie die Fahrbefehle.
Die Lok kann folglich auf den 'normalen' Fahrgleis programmiert werden.
Leider werden alle Loks, welche sich zu diesem Zeitpunkt im gleichen Stromkreis befinden gleich mit programmiert !
Man sollte folglich alle anderen Lokomotiven tunlichst entfernen, sonst handelt man sich eine Menge Arbeit ein.
Oder man speist die Stromversorgung der Anlage in ein Abstellgleis ein und verbindet die restliche Anlage über einen 2-poligen Schalter mit dem Fahrstrom.
Wenn der Schalter ausgeschaltet ist, kann man auf dem Abstellgleis problemlos programmieren.

Die Intellibox besitzt einen eigenen Ausgang für ein Programmiergleis.
Sowohl DCC, fx / mfx als auch Selectrix -Decoder werden auf diesem separaten Gleis programmiert.
Das Gleis kann während des Fahrbetriebes als normales Fahrgleis genutzt werden, muss jedoch an den Programmierausgang angeschlossen werden und darf niemals eine elektrische Verbindung mit dem 'normalen' Fahrstrom bekommen.
Ein Relais in der IB schaltet zwischen Fahrbetrieb und Programmiermodus um.

Bei der MasterControl ist es wieder anders:
Die MC hat wie die IB einen eigenen Programmierausgang, kann darüber aber nur DCC-Decoder programmieren.
Aufgrund der geringen Ausgangsleistung dieses Ausgangs ist das Testen / Fahren einer Lok auf dem Programmiergleis nicht möglich.
fx / mfx-Decoder müssen bei der MC wie bei der 6021 auf dem Fahrgleis programmiert werden.
Mit den gleichen Einschränkungen !
Das heisst, alle anderen Loks bitte entfernen oder eigenes Gleis verwenden welches niemals mit dem Fahrgleis verbunden werden darf.


Ort: Hauptmenu → Extras → Programmierhilfe

Programmierhilfe
Diese kleine Werkzeug erleichtert Ihnen die Umrechnung zwischen binär, dezimal und hexadezimal.
Die Umrechnung ist von jedem Zahlensystem in jedes Zahlensystem möglich.

Beispiele:
Sie benötigen den hexadezimalen Wert von 113
- geben Sie in das Dezimalfeld dec den Wert '113' ein,
- doppelklicken Sie darauf oder drücken Sie die Enter -Taste
Im Feld hex wird der Wert ' 71' ausgegeben, außerdem werden in der binären Anzeige die entspr. Bits gesetzt

Sie wollen wissen, welche Bits für den hexadezimalen Wert E8 zu setzen sind ?
- geben Sie in das Hexadezimalfeld hex den Wert 'E8' ein,
- doppelklicken Sie darauf oder drücken Sie die Enter -Taste
die entspr. Bits werden gesetzt und im Feld dec wird der Wert ' 232' ausgegeben.

Sie können selbstverständlich auch die verschiedenen Bits anklicken, der DecoderProgrammer berechnet sofort den entsprechenden Dezimal- und Hexadezimalwert.

→ unter den Eingabefeldern für die dezimale bzw. hexadezimalen Werte finden Sie die Optionen 7...0 und 8...1.
Obwohl die Texte unter den Eingabefelder positioniert sind, haben sie nichts damit zu tun.
Sie können damit wählen, ob die Bits von 7 bis 0 oder eben von 8 bis 1 nummeriert werden sollen.
Die meisten Decoderhersteller verwenden die korrekte Nummerierung 7...0.
In einzelnen Beschreibungen benamen die Hersteller die Bits jedoch von 8 bis 1.
Die Wahl selbst hat keinerlei direkten Einfluss auf das Ergebnis, sondern soll Ihnen lediglich die 'Übersetzung' der in der
jeweiligen Bedienungsanleitung vorgegebenen Einstellungen erleichtern.

Sie können die Programmierhilfe auch unmittelbar aus Motorola / DCC bzw. Lenz heraus aufrufen.
Klicken Sie dazu auf das + neben der Wert-Eingabe.
Das Setzen der Bits wird dann sofort in das Wert-Feld des aufrufenden Systems übertragen.


Protokoll

Der DecoderProgrammer protokolliert alle Lese- und Schreibvorgänge in der gleichnamigen Tabelle.
Sie können einzelne Vorgänge nachträglich wiederholen:
- doppelklicken Sie dazu auf die gewünschte Zeile.

Zur Auswahl weiterer Optionen zeigen Sie mit der Maus auf die Protokoll-Tabelle und klicken Sie mit der rechten Maustaste

  • Protokoll speichern
    Zum Speichern werden alle Datensätze des Protokolls verwendet, welche in der Spalte CV / Register einen Wert > 0 enthalten.
    Da der Wert "0" normalerweise nicht vorkommt, kann das Protokoll editiert werden um einzelne CVs von der Speicherung auszuschließen.
  • Protokoll editieren
    wenn Sie diesen Menupunkt wählen, können Sie das Protokoll ändern und weitere Datensätze anhängen.
    Zum Editieren stehen Ihnen aus verständlichen Gründen nur die beiden rechten Spalte zur Verfügung.
    Die 1. Spalte wird vom DecoderProgrammer mit dem Kennzeichen "E" versehen.
    Beachten Sie bitte:
    ► Änderungen an einem Datensatz werden erst dann übernommen, wenn Sie den geänderten Datensatz verlassen haben.
  • Protokoll drucken
    Der Ausdruck der Tabelle erfolgt ohne weitere Abfrage auf dem Standarddrucker.
  • Protokoll löschen
    Die Löschung erfolgt sofort, es gibt keine Sicherheitsabfrage !


MotorolaProgrammer

Ort: Hauptmenu → Extras → Schnittstelle

Schnittstellen-Konfiguration
Bevor Sie mit dem DecoderProgrammer arbeiten können, müssen Sie wahrscheinlich die Schnittstellenparameter einstellen.
Der Programmer prüft schon beim Start die Verfügbarkeit 1) der Schnittstelle,
sollte die Schnittstelle z.B.
- nicht existieren,
- durch ein anderes Gerät belegt oder
- mit einer ungültigen Baudrate angegeben sein
bekommen Sie eine entspr. Fehlermeldung und der Zugang zum Menu System wird gesperrt.

In einem solchen Fall
→ bestätigen Sie die Fehlermeldung mit OK
→ öffnen Sie im Hauptmenu das Menu Extras > Schnittstelle
→ geben Sie die Nummer einer freien Schnittstelle ein oder
klicken Sie auf COM -
das Programm sucht daraufhin alle freien 1) Schnittstellen,
- klicken Sie auf die gewünschte Schnittstelle
→ wählen Sie eine Baudrate aus der Liste oder eben Sie eine gültige Baudrate ein
(gültige Werte sind z.B. 1200,2400, 4800, 9600, 19200, 38400)
► die 6021/6051 kann nur mit 2400 Baud angesprochen werden.
→ stellen Sie dann Start- / Stop-Bits, Parity und Anzahl der Datenbits ein
► die 6021/6051 und die IB müssen mit 2 Stopbits angesprochen werden
► alle Einstellungen müssen mit den in der Zentrale eingestellten Werten übereinstimmen !
- klicken Sie auf Parameter setzen
Der Programmer prüft daraufhin Ihre Eingabe und speichert die Werte, sodass diese Ihnen bei jedem
weiteren Programmaufruf wieder zur Verfügung stehen.

► bei der zum Testen verwendeten 6021 / 6051 waren folgende DIP-Schalter gesetzt:

Interface 6051 Zentrale 6021

1 | 2 | 3 | 4 | 1 | 2 | 3 | 4
ON | ON |  |  |  | ON |  |
 |  | OFF | OFF | OFF |  | OFF | OFF

Ansicht von hinten

1) Beachten Sie bei USB-Schnittstellen, das diese immer nur solange existieren, wie das jeweilige
USB-Gerät hardwaremäßig mit dem PC verbunden und eingeschaltet ist.
D.h., solange z.B. eine über USB angesteuerte MC nicht eingeschaltet ist, wird der
DecoderProgrammer beim Start ständig die fehlende Schnittstelle 'anmeckern'.


Ort: Hauptmenu → System → Selectrix

Selectrix-Decoder programmieren mit der Zentraleinheit SLX850 oder der IntelliBox

Mit Release 2.0.21 wurde auch die Programmierung von Selectrix-Decodern eingeführt.
Die einfachen Einstellungen können sowohl mit der SLX850 als auch mit der IntelliBox gelesen und geschrieben werden.

Unterschiede zwischen SLX850 und IB
- die erweiterten Einstellungen können nur mit der SLX850 gelesen und geschrieben werden
- das Programmier-Bit lässt sich nur mit der SLX850 ausschalten
- das Fahrpult steht nur bei der zur SLX850 Verfügung
a b e r
- die IntelliBox benötigt sowohl für das Lesen als auch für das Schreiben nur etwa 1/10 (!) der Zeit der SLX850


Ort: Hauptmenu → System → Selectrix

Selectrix-Decoder programmieren mit der Zentraleinheit SLX850

Selectrix-Decoder

→ Die Lok muss sich zum Lesen und Schreiben eines Decoders auf einem separaten
Programmiergleis befinden.

Zum Lesen eines Decoders genügt es, die Taste lesen anzuklicken, der DecoderProgrammer baut damit die Kommunikation zur Zentrale auf und zeigt den jeweiligen Fortschritt in der Statuszeile unten links an.
Nach Abschluss des Lesevorganges wird das Ergebnis in den zugehörigen Feldern angezeigt.
Außerdem wird ein Datensatz im Kommunikationsprotokoll angelegt.

Durch Öffnen der entspr. Listen können Sie die verschiedenen Parameter verändern.
Um fehlerhafte Eingaben zu verhindern (z.B. Adresse > 103, Höchstgeschw. > 7 usw.) sind direkte Eingaben nicht möglich, der entspr. Wert kann nur aus der jeweiligen Liste entnommen werden.

Wenn alle Eingaben Ihren Wünschen entsprechen, klicken Sie bitte auf schreiben .
Damit werden Ihre Vorgaben in den Decoder geschrieben.
Auch dieser Vorgang wird in der Statuszeile kommentiert und im Kommunikationsprotokoll festgehalten.

Nach einem Lesevorgang kann
- die Drehrichtung des Motors
- Spitzenlicht und Zugschluss getauscht werden und
- die Gleispolarität
- die Impulsbreite
- die Anzahl der Halteabschnitte
geändert werden.
Klicken Sie dazu auf erweiterte Einstellungen .
Einzelheiten zu den einzelnen Auswirkungen entnehmen Sie bitte der Bedienungsanleitung des jeweiligen Decoders.

► Mit den Tasten Power off und Power on können Sie die Verbindung zur Zentrale prüfen.
Solange diese Befehle von der Steuereinheit nicht erkannt und ausgeführt werden, wird auch
die Decoder-Programmierung nicht funktionieren.

► Bei den Tests kam es in wenigen Fällen vor, dass der Decoder nicht aus dem Programmiermodus herauskam,
die Lok 'muckelt' dann leicht vor sich hin. In einem solchen Fall kann mit der Taste Prog.mode aus
der Programmiermodus beendet werden.

► Unterhalb des Fahrpultes befindet sich das Feld delay - dieses hat folgende Bewandtnis:
die Kommunikation mit einem Decoder geht längst nicht so schnell, wie die jeweilige Schnittstelle erlaubt.
Die Decoder brauchen immer etwas Zeit, um die einzelnen Kommandos 'zu verdauen'. Diese Zeitspanne
kann selbst bei baugleichen Decodern durchaus unterschiedlich sein. Mit dem Verzögerungswert
können Sie die Zeit in Millisekunden einstellen, welche der DecoderProgrammer zwischen den einzelnen
Kommandos wartet.
Je größer der Wert, umso sicherer ist die Übertragung, aber umso länger dauert sie auch

DCC-Decoder

Nach Wahl des DCC-Modus erscheint die Eingabemaske für die DCC-Programmierung.
Sie können die gewünschte CV
- von Hand in das Textfeld eingeben,
- mit dem Scrollregler einstellen oder
- in der Liste anklicken.
Der wählbare Bereich liegt zwischen 1 und 999.

Den in die gewählte CV zu schreibenden Wert können Sie
- von Hand eingeben oder
- mit dem Scrollregler einstellen.

► Der DecoderProgrammer verhindert zwar Werte > 255, aber längst nicht jede CV verträgt jeden Wert !
Es liegt alleine in Ihrer Verantwortung, welchen Wert Sie in den Decoder schreiben.

► Beim Lesen und Schreiben von DCC-Decodern wird im Kommunikationsprotokoll in der
Spalte GE der jeweilige Wert der CV ausgegeben.
In der Spalte BE erscheint zusätzlich der Hinweis 'DCC'

Da das SLX-System keinerlei Kontrolle der Übertragung kennt, empfiehlt es sich, nach dem Schreiben eines Decoders einen Lesevorgang durchzuführen, um evt. Übertragungsfehler ausschließen zu können.


Ort: Hauptmenu → System → Selectrix

Selectrix-Decoder programmieren mit der IntelliBox

Selectrix-Decoder

→ Die Lok muss sich zum Lesen und Schreiben eines Decoders auf einem separaten
Programmiergleis befinden.

→ Mit der IntelliBox lassen sich nur die einfachen Einstellungen lesen und schreiben

Zum Lesen eines Decoders genügt es, die Taste lesen anzuklicken, der DecoderProgrammer baut damit die Kommunikation zur Zentrale auf und zeigt den jeweiligen Fortschritt in der Statuszeile unten links an.
Nach Abschluss des Lesevorganges wird das Ergebnis in den zugehörigen Feldern angezeigt.
Außerdem wird ein Datensatz im Kommunikationsprotokoll angelegt.

Durch Öffnen der entspr. Listen können Sie die verschiedenen Parameter verändern.
Um fehlerhafte Eingaben zu verhindern (z.B. Adresse > 103, Höchstgeschw. > 7 usw.) sind direkte Eingaben nicht möglich, der entspr. Wert kann nur aus der jeweiligen Liste entnommen werden.

Wenn alle Eingaben Ihren Wünschen entsprechen, klicken Sie bitte auf schreiben .
Damit werden Ihre Vorgaben in den Decoder geschrieben.
Auch dieser Vorgang wird in der Statuszeile kommentiert und im Kommunikationsprotokoll festgehalten.

DCC-Decoder

DCC-Decoder können in diesem Menu mit der IntelliBox bearbeitet nicht werden. Gehen Sie dazu nach:

Hauptmenu > System > Motorola / DCC

Da das SLX-System keinerlei Kontrolle der Übertragung kennt, empfiehlt es sich, nach dem Schreiben eines Decoders einen Lesevorgang durchzuführen, um evt. Übertragungsfehler ausschließen zu können.